Skip to main content
← All vulnerabilities
CVE-2024-45384GHSA-P72W-R6FV-6G5H

Apache Druid: Padding oracle in druid-pac4j extension that allows an attacker to manipulate a pac4j session cookie via Padding Oracle Attack

Published
Last modified
published
Not listed in CISA KEV
Low (apache)
Fix
Fixed in 30.0.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Padding Oracle vulnerability in Apache Druid extension, druid-pac4j. This could allow an attacker to manipulate a pac4j session cookie. This issue affects Apache Druid versions 0.18.0 through 30.0.0. Since the druid-pac4j extension is optional and disabled by default, Druid installations not using the druid-pac4j extension are not affected by this vulnerability. While we are not aware of a way to meaningfully exploit this flaw, we nevertheless recommend upgrading to version 30.0.1 or higher which fixes the issue and ensuring you have a strong druid.auth.pac4j.cookiePassphrase as a precaution.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • org.apache.druid.extensions:druid-pac4j

    From 0.18.0 · through 30.0.0

  • org.apache.druid.extensions:druid-pac4jMaven

    From 0.18.0 · fixed in 30.0.1

References 1

lists.apache.org