Skip to main content
← All vulnerabilities
CVE-2024-45312

Arbitrary language parameter can passed to `aspell` executable via spelling requests in overleaf

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.2.7, 5.0.7
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

Overleaf is a web-based collaborative LaTeX editor. Overleaf Community Edition and Server Pro prior to version 5.0.7 (or 4.2.7 for the 4.x series) contain a vulnerability that allows an arbitrary language parameter in client spelling requests to be passed to the `aspell` executable running on the server. This causes `aspell` to attempt to load a dictionary file with an arbitrary filename. File access is limited to the scope of the overleaf server. The problem is patched in versions 5.0.7 and 4.2.7. Previous versions can be upgraded using the Overleaf toolkit `bin/upgrade` command. Users unable to upgrade may block POST requests to `/spelling/check` via a Web Application Firewall will prevent access to the vulnerable spell check feature. However, upgrading is advised.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • overleaf overleaf

    From 4.0.0 · fixed in 4.2.7; From 5.0.0 · fixed in 5.0.7

References 3

GitHub · overleaf/overleaf

GitHub · overleaf/toolkit