Skip to main content
← All vulnerabilities
CVE-2024-45290GHSA-5GPR-W2P5-6M37

Path traversal and Server-Side Request Forgery when opening XLSX files in PHPSpreadsheet

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.29.2, 2.1.1, 2.3.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

PHPSpreadsheet is a pure PHP library for reading and writing spreadsheet files. It's possible for an attacker to construct an XLSX file which links media from external URLs. When opening the XLSX file, PhpSpreadsheet retrieves the image size and type by reading the file contents, if the provided path is a URL. By using specially crafted `php://filter` URLs an attacker can leak the contents of any file or URL. Note that this vulnerability is different from GHSA-w9xv-qf98-ccq4, and resides in a different component. An attacker can access any file on the server, or leak information form arbitrary URLs, potentially exposing sensitive information such as AWS IAM credentials. This issue has been addressed in release versions 1.29.2, 2.1.1, and 2.3.0. All users are advised to upgrade. There are no known workarounds for this vulnerability.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • PHPOffice PhpSpreadsheet

    fixed in 1.29.2; From 2.0.0 · fixed in 2.1.1; From 2.2.0 · fixed in 2.3.0

  • phpoffice/phpspreadsheetPackagist

    From 2.2.0 · fixed in 2.3.0

  • phpoffice/phpspreadsheetPackagist

    fixed in 1.29.2

  • phpoffice/phpspreadsheetPackagist

    From 2.0.0 · fixed in 2.1.1

  • phpoffice/phpexcelPackagist

    through 1.8.2

References 2

GitHub · PHPOffice/PhpSpreadsheet