Skip to main content
← All vulnerabilities
CVE-2024-45127GHSA-C89G-GQ5R-2XW2BIT-MAGENTO-2024-45127

Adobe Commerce | Cross-site Scripting (Stored XSS) (CWE-79)

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Adobe Commerce versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10 and earlier are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an admin attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Adobe Adobe Commerce

    through 2.4.4-p10

  • magento/community-editionPackagist

    From 2.4.7-beta1 · fixed in 2.4.7-p3

  • magento/community-editionPackagist

    From 2.4.6-p1 · fixed in 2.4.6-p8

  • magento/community-editionPackagist

    From 2.4.5-p1 · fixed in 2.4.5-p10

  • magento/community-editionPackagist

    fixed in 2.4.4-p11

  • magento/community-editionPackagist

    2.4.7

  • magento/community-editionPackagist

    2.4.6

  • magento/community-editionPackagist

    2.4.5

  • magento/community-editionPackagist

    2.4.4

References 1

helpx.adobe.com