CVE-2024-45119GHSA-G9FM-WC6H-PVGJ
Adobe Commerce | Server-Side Request Forgery (SSRF) (CWE-918)
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
Adobe Commerce versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10 (and earlier) are affected by a Server-Side Request Forgery (SSRF) vulnerability that could lead to arbitrary file system read. An admin-privilege authenticated attacker can force the application to make arbitrary requests via injection of arbitrary URLs. Exploitation of this issue does not require user interaction.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- Adobe Adobe Commerce
through 2.4.4-p10
- magento/community-editionPackagist
From 2.4.7-beta1 · fixed in 2.4.7-p3
- magento/community-editionPackagist
From 2.4.6-p1 · fixed in 2.4.6-p8
- magento/community-editionPackagist
From 2.4.5-p1 · fixed in 2.4.5-p10
- magento/community-editionPackagist
fixed in 2.4.4-p11
- magento/community-editionPackagist
2.4.7
- magento/community-editionPackagist
2.4.6
- magento/community-editionPackagist
2.4.5
- magento/community-editionPackagist
2.4.4