Skip to main content
← All vulnerabilities
CVE-2024-45117GHSA-3FR3-GCQH-3M2G

Adobe Commerce | Improper Input Validation (CWE-20)

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Adobe Commerce versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10 and earlier are affected by an Improper Input Validation vulnerability that could lead to arbitrary file system read. An admin attacker could exploit this vulnerability to read files from the system outside of the intended directories via PHP filter chain and also can have a low-availability impact on the service. Exploitation of this issue does not require user interaction and scope is changed.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Adobe Adobe Commerce

    through 2.4.4-p10

  • magento/community-editionPackagist

    From 2.4.7-beta1 · fixed in 2.4.7-p3

  • magento/community-editionPackagist

    From 2.4.6-p1 · fixed in 2.4.6-p8

  • magento/community-editionPackagist

    From 2.4.5-p1 · fixed in 2.4.5-p10

  • magento/community-editionPackagist

    fixed in 2.4.4-p11

  • magento/community-editionPackagist

    2.4.7

  • magento/community-editionPackagist

    2.4.6

  • magento/community-editionPackagist

    2.4.5

  • magento/community-editionPackagist

    2.4.4

References 1

helpx.adobe.com