Skip to main content
← All vulnerabilities
CVE-2024-45116GHSA-873M-72G6-853G

Adobe Commerce | Cross-site Scripting (XSS) (CWE-79)

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Adobe Commerce versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10 and earlier are affected by a Cross-Site Scripting (XSS) vulnerability that could be exploited to execute arbitrary code. If an admin attacker can trick a user into clicking a specially crafted link or submitting a form, malicious scripts may be executed within the context of the victim's browser and have high impact on confidentiality and integrity. Exploitation of this issue requires user interaction.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Adobe Adobe Commerce

    through 2.4.4-p10

  • magento/community-editionPackagist

    From 2.4.7-beta1 · fixed in 2.4.7-p3

  • magento/community-editionPackagist

    From 2.4.6-p1 · fixed in 2.4.6-p8

  • magento/community-editionPackagist

    From 2.4.5-p1 · fixed in 2.4.5-p10

  • magento/community-editionPackagist

    fixed in 2.4.4-p11

  • magento/community-editionPackagist

    2.4.7

  • magento/community-editionPackagist

    2.4.6

  • magento/community-editionPackagist

    2.4.5

  • magento/community-editionPackagist

    2.4.4

References 1

helpx.adobe.com