Skip to main content
← All vulnerabilities
CVE-2024-4350GHSA-Q5WX-M95R-4CGC

Concrete CMS version 9 below 9.3.3 and below 8.5.18 are vulnerable to Stored XSS in RSS Displayer

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.3.3, 8.5.18
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Concrete CMS versions 9.0.0 to 9.3.2 and below 8.5.18 are vulnerable to Stored XSS in RSS Displayer when user input is stored and later embedded into responses. A rogue administrator could inject malicious code into fields due to insufficient input validation. The Concrete CMS security team gave this vulnerability a CVSS v4 score of 5.1 with vector https://www.first.org/cvss/calculator/4.0#CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N Thanks, m3dium for reporting. (CNA updated this risk rank on 17 Jan 2025 by lowering the AC based on CVSS 4.0 documentation that access privileges should not be considered for AC)

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Concrete CMS Concrete CMS

    From 9.0.0 · fixed in 9.3.3; From 5.0.0 · fixed in 8.5.18

  • concrete5/concrete5Packagist

    fixed in 8.5.18

  • concrete5/concrete5Packagist

    From 9.0.0RC1 · fixed in 9.3.3

References 4

GitHub · concretecms/concretecms

documentation.concretecms.org