Skip to main content
← All vulnerabilities
CVE-2024-42447PYSEC-2026-1146GHSA-62QF-QM3G-FVCWPYSEC-2024-265

Apache Airflow Providers FAB: FAB provider 1.2.1 and 1.2.0 did not let user to logout for Airflow

Published
Last modified
published
Not listed in CISA KEV
Low (apache)
Fix
Fixed in 1.2.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

Insufficient Session Expiration vulnerability in Apache Airflow Providers FAB. This issue affects Apache Airflow Providers FAB: 1.2.1 (when used with Apache Airflow 2.9.3) and FAB 1.2.0 for all Airflow versions. The FAB provider prevented the user from logging out.   • FAB provider 1.2.1 only affected Airflow 2.9.3 (earlier and later versions of Airflow are not affected) • FAB provider 1.2.0 affected all versions of Airflow. Users who run Apache Airflow 2.9.3 are recommended to upgrade to Apache Airflow Providers FAB version 1.2.2 which fixes the issue. Users who run Any Apache Airflow version and have FAB provider 1.2.0 are recommended to upgrade to Apache Airflow Providers FAB version 1.2.2 which fixes the issue. Also upgrading Apache Airflow to latest version available is recommended. Note: Early version of Airflow reference container images of Airflow 2.9.3 and constraint files contained FAB provider 1.2.1 version, but this is fixed in updated versions of the images.  Users are advised to pull the latest Airflow images or reinstall FAB provider according to the current constraints.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • apache-airflow-providers-fab

    From 1.2.0 · through 1.2.1

  • apache-airflow-providers-fabPyPI

    From 1.2.0 · fixed in 1.2.2

  • apache-airflowPyPI

    through 1.2.1; through 1.2.0

References 2

GitHub · apache/airflow

lists.apache.org