Skip to main content
← All vulnerabilities
CVE-2024-42356GHSA-35JP-8CGG-P4WJ

Shopware vulnerable to Server Side Template Injection in Twig using Context functions

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 6.5.8.13, 6.6.5.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: total

Summary

Shopware is an open commerce platform. Prior to versions 6.6.5.1 and 6.5.8.13, the `context` variable is injected into almost any Twig Template and allows to access to current language, currency information. The context object allows also to switch for a short time the scope of the Context as a helper with a callable function. The function can be called also from Twig and as the second parameter allows any callable, it's possible to call from Twig any statically callable PHP function/method. It's not possible as customer to provide any Twig code, the attacker would require access to Administration to exploit it using Mail templates or using App Scripts. Update to Shopware 6.6.5.1 or 6.5.8.13 to receive a patch. For older versions of 6.1, 6.2, 6.3 and 6.4 corresponding security measures are also available via a plugin.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • shopware shopware

    through 6.5.8.12; From 6.6.0.0 · through 6.6.5.0

  • shopware/corePackagist

    fixed in 6.5.8.13

  • shopware/platformPackagist

    fixed in 6.5.8.13

  • shopware/platformPackagist

    From 6.6.0.0 · fixed in 6.6.5.1

  • shopware/corePackagist

    From 6.6.0.0 · fixed in 6.6.5.1

References 5

GitHub · shopware/shopware

GitHub · shopware/core