Skip to main content
← All vulnerabilities
CVE-2024-42354GHSA-HHCQ-PH6W-494G

Shopware vulnerable to Improper Access Control with ManyToMany associations in store-api

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 6.5.8.13, 6.6.5.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Shopware is an open commerce platform. The store-API works with regular entities and not expose all fields for the public API; fields need to be marked as ApiAware in the EntityDefinition. So only ApiAware fields of the EntityDefinition will be encoded to the final JSON. Prior to versions 6.6.5.1 and 6.5.8.13, the processing of the Criteria did not considered ManyToMany associations and so they were not considered properly and the protections didn't get used. This issue cannot be reproduced with the default entities by Shopware, but can be triggered with extensions. Update to Shopware 6.6.5.1 or 6.5.8.13 to receive a patch. For older versions of 6.2, 6.3, and 6.4, corresponding security measures are also available via a plugin.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • shopware shopware

    through 6.5.8.12; From 6.6.0.0 · through 6.6.5.0

  • shopware/corePackagist

    fixed in 6.5.8.13

  • shopware/platformPackagist

    fixed in 6.5.8.13

  • shopware/corePackagist

    From 6.6.0.0 · fixed in 6.6.5.1

  • shopware/platformPackagist

    From 6.6.0.0 · fixed in 6.6.5.1

References 5

GitHub · shopware/shopware

GitHub · shopware/core