CVE-2024-4198GO-2024-2794GHSA-5QX9-9FFJ-5R8F
Mattermost versions 9.6.0, 9.5.x before 9.5.3, and 8.1.x before 8.1.12 fail to fully validate role changes which allows an attacker authenti
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 8.1.12+incompatible, 9.5.3+incompatible, 9.6.1+incompatible, 9.6.1, 9.5.3, and 1 more
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
Mattermost versions 9.6.0, 9.5.x before 9.5.3, and 8.1.x before 8.1.12 fail to fully validate role changes which allows an attacker authenticated as team admin to demote users to guest via crafted HTTP requests.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- Mattermost Mattermost
From 9.5.0 · through 9.5.2; From 8.1.0 · through 8.1.11
- github.com/mattermost/mattermost-serverGo
From 8.1.0+incompatible · fixed in 8.1.12+incompatible; From 9.5.0+incompatible · fixed in 9.5.3+incompatible; From 9.6.0-rc1+incompatible · fixed in 9.6.1+incompatible
- github.com/mattermost/mattermost-serverGo
From 9.6.0-rc1 · fixed in 9.6.1
- github.com/mattermost/mattermost-serverGo
From 9.5.0 · fixed in 9.5.3
- github.com/mattermost/mattermost-serverGo
From 8.1.0 · fixed in 8.1.12