Skip to main content
← All vulnerabilities
CVE-2024-41942PYSEC-2024-200BIT-JUPYTERHUB-2024-41942GHSA-9X4Q-3GXW-849F

JupyterHub has a privilege escalation vulnerability with the `admin:users` scope

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.1.6, 5.1.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

JupyterHub is software that allows one to create a multi-user server for Jupyter notebooks. Prior to versions 4.1.6 and 5.1.0, if a user is granted the `admin:users` scope, they may escalate their own privileges by making themselves a full admin user. The impact is relatively small in that `admin:users` is already an extremely privileged scope only granted to trusted users. In effect, `admin:users` is equivalent to `admin=True`, which is not intended. Note that the change here only prevents escalation to the built-in JupyterHub admin role that has unrestricted permissions. It does not prevent users with e.g. `groups` permissions from granting themselves or other users permissions via group membership, which is intentional. Versions 4.1.6 and 5.1.0 fix this issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • jupyterhub jupyterhub

    fixed in 4.1.6; From 5.0.0 · fixed in 5.1.0

  • jupyterhubPyPI

    fixed in 4.1.6

  • jupyterhubPyPI

    From 5.0.0 · fixed in 5.1.0

References 3

GitHub · jupyterhub/jupyterhub