Skip to main content
← All vulnerabilities
CVE-2024-41926GO-2024-3022BIT-MATTERMOST-2024-41926GHSA-9FPW-C9X7-CV3J

Malicious remote can claim that a user was synced from another remote

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.5.7+incompatible, 9.9.1+incompatible, 9.5.7, 9.9.1, 8.0.0-20240604093018-5114c3b7cdb8, and 1 more
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Mattermost versions 9.9.x <= 9.9.0 and 9.5.x <= 9.5.6 fail to validate the source of sync messages and only allow the correct remote IDs, which allows a malicious remote to set arbitrary RemoteId values for synced users and therefore claim that a user was synced from another remote.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Mattermost Mattermost

    From 9.5.0 · through 9.5.6

  • github.com/mattermost/mattermost-serverGo

    From 9.5.0+incompatible · fixed in 9.5.7+incompatible; From 9.9.0+incompatible · fixed in 9.9.1+incompatible

  • github.com/mattermost/mattermost-server/v5Go

    All versions

  • github.com/mattermost/mattermost-server/v6Go

    All versions

  • github.com/mattermost/mattermost/server/v8Go

    All versions

  • github.com/mattermost/mattermost/server/v8Go

    From 9.5.0 · fixed in 9.5.7

  • github.com/mattermost/mattermost/server/v8Go

    From 9.9.0 · fixed in 9.9.1

  • github.com/mattermost/mattermost/server/v8Go

    fixed in 8.0.0-20240604093018-5114c3b7cdb8

  • github.com/mattermost/mattermostGo

    fixed in 5.3.2-0.20240604093018-5114c3b7cdb8

References 1

mattermost.com