Skip to main content
← All vulnerabilities
CVE-2024-4183GO-2024-2798GHSA-WJ37-MPQ9-XRCM

Mattermost versions 8.1.x before 8.1.12, 9.6.x before 9.6.1, 9.5.x before 9.5.3, 9.4.x before 9.4.5 fail to limit the number of active sessi

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 8.1.12+incompatible, 9.4.5+incompatible, 9.5.3+incompatible, 9.6.1+incompatible, 9.6.1, and 3 more
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Mattermost versions 8.1.x before 8.1.12, 9.6.x before 9.6.1, 9.5.x before 9.5.3, 9.4.x before 9.4.5 fail to limit the number of active sessions, which allows an authenticated attacker to crash the server via repeated requests to the getSessions API after flooding the sessions table.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Mattermost Mattermost

    From 9.6.0 · through 8.1.10; From 9.5.0 · through 9.5.2; From 9.4.0 · through 9.4.4; From 8.1.0 · through 8.1.11

  • github.com/mattermost/mattermost-serverGo

    From 8.1.0+incompatible · fixed in 8.1.12+incompatible; From 9.4.0+incompatible · fixed in 9.4.5+incompatible; From 9.5.0+incompatible · fixed in 9.5.3+incompatible; From 9.6.0-rc1+incompatible · fixed in 9.6.1+incompatible

  • github.com/mattermost/mattermost-serverGo

    From 9.6.0-rc1 · fixed in 9.6.1

  • github.com/mattermost/mattermost-serverGo

    From 9.5.0 · fixed in 9.5.3

  • github.com/mattermost/mattermost-serverGo

    From 9.4.0 · fixed in 9.4.5

  • github.com/mattermost/mattermost-serverGo

    From 8.1.0 · fixed in 8.1.12

References 1

mattermost.com